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1 General

1.1 Who is this guide for?
In addition to manually submitting a data report, the LUCID Packaging Register has XML upload

functionality for report submission. This guide is for anyone interested in creating an XML file for
this purpose, but it only relates to producer data reports.
1.2 When is it helpful to use the XML interface?

Using XML interfaces can make submitting data reports in the LUCID Packaging Register simpler.
The producer uses the file to automatically upload the same data report that it submitted to its
system operator.

1.3 General information about the XML interface

1.3.1 Character encoding
The character encoding for the XML file must be UTF-8-BOM.

To check the character encoding of the file, you can use Notepad++ (for example). In the menu
bar, click on Encoding and make sure that Encode in UTF-8-BOM is selected.

LUCID only accepts Latin-1, Latin-2 and Latin-3 coding characters.

[ new 1- Notepad++ — O X
File Edit Search View  Encoding Language Settings Tools Macre PRun Plugins Window 7 X
sEEHE % & Encode in ANS| 2 BEE|ZT1EEEAE®| = EDBEB|H &

Hnew 16| i
T [® Encode in UTF-3-80M
Encode in UCS-2 BE BOM
Encode in UCS-2 LEEOM
Character sets »

Convert to ANSI

Convert to UTF-2

Convert to UTF-8-BOM
Convert to UC5-2 BEBOM
Convert to UCS-2 LE BOM

1.3.2 XML file validation

An XML file can be validated with the help of an XML schema. The usual file extension for an
XML schema is .xsd'". To carry out the check, you can use Notepad++ with the 'XML Tools' plugin
(for example).
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Follow these steps to validate the XML file:
1. Open Notepad++.
2.  Click on File => Open, select the XML file you would like to validate and click Open.
3.  Click on Plugins => XML tools => Validate now.

Datei Bearbeiten Suchen Ansicht Kodierung Sprachen FEinstellingen Werkzeuge Makro Ausfuhren | Erweiterungen  Fenster ?

sDHaERHe i MR an ax|BE|SHT1EEBRNE DSpeliCheck >
B Aufgaben t (3| Bl Fragen bt (3| B Dokumentation EHR ¢ £3] BIMODE Matken DE 2021 dovum 3| Bl weGet ~ MIME Tools > XML Markennamen @ 3] B EMP_Matken_20223m £3| B proccers_14042022_06
1 k2xml version="1.0"2> Converter 2
2 E<Root xmlns:xsi="http://www.w3.org/2001/XMLSchema-insta | XMLTools B[S Enable XML syntax auto-check
3 <VersionNoInterface>1.1</VersionNoInterface> Open Plugins Folder... Check XML syntax now
4 <istofBrands> Enable auto-validation
3 <Brand> Validate now Ctrl+Alts Shift=
6 Br Marke_A</Brand
7 <PackagingDetailCode>10</PackagingDetailCode> ¥ Tagauto-close
S </Brand> V| Set XML type automatically
] <Rzandy V| PreventXXE
10 <BrandName>Marke B</BrandName> o
11 <PackagingDetailCode>20</PackagingDetailCode> NSRS
12 </Brand> Pretty print Ctrl+Alt+Shift+B
i =] <Brand> Pretty print (indent attributes) Ctrl+Alt+Shift+A
14 <BrandName>Marke_C</BrandName> Pretty print - indent only
15 <PackagingDetailCode>30</PackagingDetailCode> Vinesrize Ctrl+Alts Shift+L
ol </Brand> Apply to all open files
17 | </ListofBrands>
18 </Root> Current XML Path

Current XML Path with predicates Ctrl+Alt+Shift+P
Evaluate XPath expression...

XSL Transformation...

Escape characters in selection (<> — &t:&gt)

Unescape characters in selection (&t;&gt; — <>)

Comment selection Ctrl+AltShift+ C
Uncomment selection Ctrl+Alt+Shift=R
Options...

Debug window...

About XML Tools / Donate...

4. Click on the button with the three dots, select the XML schema and confirm by clicking
OK.

Select file... *

Flease select XML schema (<5D):

| L]

Impartant:

This dialog box is displayed because default validation schema cannot be found in <ML root
element. Ta avaoid having to specify the %50 for every validation, pleaze define the default
#ML zchema in pour root element using following syntas:

<Root
wmlng:zi="http: /v w3, org/ 2001 A<MLS chema-instance'
#si:noM amespaceSchemalocation="=<50_FILE_PATH":

where X50_FILE_PATH is the relative or absolute path of the XML schema file.

Cancel

5. Repeat this process until no further errors are displayed. A file must be valid to be up-
loaded in LUCID. If the XML file is valid, the following message will be displayed:

XML Tools plugin

a ;x: is:c:lv:vahdahon:
2 Producer volume report interface (sec-
tion 10 VerpackG)

Stiftung Zentrale Stelle Verpackungsregister | Foundation headquarters: City of Osnabriick | Chair: Gunda Rachut
Foundation authorities: Amt fur regionale Landesentwicklung Weser-Ems (Weser-Ems Office for Regional State Development) | Foun-
dation register no.: 16 (085)

@ 4



— LUCID

2.1

Gemeinsam
Transparenz schaffen

How can | use the XML interface?

Stiftung
Zentrale Stelle

VERPACKUNGSREGISTER

’

To be able to use the XML interface, you need to create and upload a valid XML file with the
correct schema.

In order to make XML data reporting as simple as possible, all of the information that is relevant
for the fields in a manual report is included in the XML file. After the file has been uploaded, the

data is displayed and must be confirmed by the user.

Below is a sample XML file for uploading volume reports with explanations:
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2.2

*»

»

<?xml version="1.0"2>

EJ<Root>
<VersionNoInterface>1.0< 2 nterface>
<PackagingTypeCode>V</PackagingIypeCad

<TypeOfRepo:cCode>BPM12/TypeOfRepoxcCode>

Enter the PackagingTypeCode here (currently
only V is allowed).
Enter the TypeOfReportCode here.

Enter the start date for the reporting

<ReportingPeriodFrom>2019-01-01</ReportingPeriodFrom>
<ReportingPeriodTo>2019-12-31</ReportingPeriodTo>

period here.

<ListOfSystemOperators>

Enter the end date for the reporting
period here.

<SystemOperator>
<5yscemOperacorID>xx1234§i§i§6789</Syscem0peratorID>
<ListOfMaterials>
<Material>

<MaterialCode>10000</MaterialCode>

———

<Mass>3244,000</Mass>

</Material>

<Material>
<MaterialCode>20000</MaterialCode>
<Mass>1234,542</Mass>

</Material>

<Material>
<MaterialCode>30000</MaterialCode>
<Mass>54,125</Mass>

</Material>

<Material>
<MaterialCode>40000</MaterialCode>
<Mass>19518,456</Mass>

</Material>

<Material>
<MaterialCode>80000</MaterialCode>
<Mass>2084,254</Mass>

</Material>

<Material>
<MaterialCode>50000</MaterialCode>
<Mass>21003,999</Mass>

</Material>

<Material>
<MaterialCode>60000</MaterialCode>
<Mass>541,258</Mass>

</Material>

</ListOfMaterials>
</SystemOperator>

F</ListOfSystemOperators>
-</Root>

Information about the elements

Enter the SystemOperatorlD for the
volume you are reporting here.

Enter the MaterialCode here.
Enter the mass of the packaging for that

MaterialCode here.

Other information:
- The first, second, third and last lines create the

framework for the XML file. They are mandatory
and must not be changed.

A list of valid codes can be found in the next
chapter.

If you have contracted with multiple system
operators, you can copy the section starting with
<SystemOperator> up to and including
</SystemOperator> under
ListOfSystemOperators to add other system
operators.

The first two lines and the last line are the 'bones' of the XML file. These lines may not be
changed.
VersionNolnterface: the version number relates to the technical version of the interface; the
current interface version number is 1.0.
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» PackagingTypeCode: code for 'packaging' (V). Other options are technically possible, but
not permitted at this time. For details, refer to 2.3.1.2 Table: Packaging types.

» TypeOfReportCode: code for initial planned volume report, intra-year volume report, year-
end volume report, supplementary volume report or deducted volumes. For details, refer to
2.3.1.3 Table: Producer report types.

» ReportingPeriodFrom: period of the report (date YYYY-MM-DD); only month and year are
applied.

® ReportingPeriodTo: period of the report (date YYYY-MM-DD); only month and year are ap-
plied.

» SystemOperatorlD: conclusive identification number of the system operator for the ZSVR.
For details, refer to 2.3.1.4 Table: System operator.

*® MaterialCode: code for material type. Depending on the reporting period, the material types
are based on the Packaging Ordinance (Verpackungsverordnung — VerpackV) (year-end
report, supplementary volume report, deducted volume report for 2018) or the Packaging
Act (Verpackungsgesetz — VerpackG) (from 2019 onwards, even if filed in 2018). The Ma-
terialCodes can be found in 2.3.1.1 Table: Material type overview.

*» Mass: packaging material mass in kg to the third decimal place without thousands separa-
tors (decimal place demarcated with comma).

2.2.1 Reported volumes

Depending on report types, a distinction needs to be made between different reported volumes.
The report types initial planned volume report, intra-year volume report, year-end volume report
and deducted volumes are always full reports. The supplementary volume report is an additive
report.

» Full report: provides the total volume for the reporting period. Where information already
exists for a given reporting period, a new file will replace it if the correction window is still
open.

» Where information already exists for a given reporting period, a new file will replace it if the
correction window is still open.

*» Additive report: provides the difference between the previous and the new volume for the
reporting period. Where information already exists for a given reporting period, the new
information will be added to the existing information. Negative values can also be entered.

2.3 Information about the codes

The reports in 2019 for the 2018 reporting year must be filed according to the material types in
the Verpackungsverordnung (VerpackV) exclusively. Reports for 2019 onwards are filed on the
basis of the material types in the Verpackungsgesetz (VerpackG).

Stiftung Zentrale Stelle Verpackungsregister | Foundation headquarters: City of Osnabriick | Chair: Gunda Rachut
Foundation authorities: Amt fur regionale Landesentwicklung Weser-Ems (Weser-Ems Office for Regional State Development) | Foun-
dation register no.: 16 (085)

@6



—" Stiftung
‘ IG-enlv.ejugrrIrD Q Zentrale Stelle

Transparenz schaffen VERPACKUNGSREGISTER

2.3.11 Table: Material type overview

MELIENPTEES \I\ﬁlzrtzer]ic;il(gode \I\ileartg?icall(gode
Glass 10000 10000
PPC 20000 20000
Tinplate 39000

Ferrous metals 30000
Aluminium 49000 40000
Plastics 50000 50000
Beverage carton packaging 60000
Composite materials 79000

Other composite packaging 70000
Other materials 80000 80000

2.31.2 Table: Packaging types

The packaging types are listed in the following table. Currently the only packaging type allowed
is 'packaging'.

Packaging type PackagingTypeCode

Packaging \%

2.31.3 Table: Producer report types

Type of report TypeOfReportCode: | Reported volumes
Initial planned volume report HPM1 Full report
Intra-year volume report HMM1 Full report
Year-end volume report HJM1 Full report
Supplementary volume report HNM1 Additive report
Deducted volumes HAM1 Full report
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2314 Table: System operator

System operator SystemOperatorID

Interzero Circular Solutions Germany GmbH DE6005779374130
Reclay Systems GmbH DE6005973594801
RKD Recycling Kontor Dual GmbH & Co. KG DE6006382012686
Der Grine Punkt — Duales System Deutschland GmbH DE6004919627351
Landbell AG fir Riickhol-Systeme DE6005906579671
Noventiz Dual GmbH DE6005959764031
Zentek GmbH & Co. KG DE6007094250999
Veolia Umweltservice Dual GmbH DE6007086225568
ELS Europaische LizenzierungsSysteme GmbH DE6007168805143
BellandVision GmbH DE6004738522858
PreZero Dual GmbH DE6004844021815
EKO-PUNKT GmbH & CO. KG DE6007780383579
Recycling Dual GmbH DE6257129182400
INTERSEROH+ GmbH DE6161328237553
Altera System GmbH DE6229413357273

2.4 Other information

The XML file is not saved permanently by the ZSVR and only serves to transfer the data to the
web interface. Being able to submit a data report can depend on factors like registration status or
packaging details; this applies to both manual and XML upload data report submission. In addi-
tion, there are technical plausibility checks, such as version, format, logic, completeness and
structural checks. As such, a valid XML file (in relation to the XML schema) may be refused. Only
once the XML file has been corrected, made free of any errors and uploaded can the data be
saved.

The 'ReportingPeriodFrom' and 'ReportingPeriodTo' must always be in the same calendar year.
XML data reports that span multiple years are not permitted. In such a case, two files must be
uploaded.

The material codes in the XML file can be entered in any order. If the volume of a material is 0.000
kg, then the entire MaterialCode with mass (including the Material start and end tag) can be left
out as an alternative.
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