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I. Document version history 
 

 

CHANGE HISTORY 

Date Version Change/update Author 

30 August 2018 1.0 Description: brand name XML 

interface 

Stiftung Zentrale Stelle 

Verpackungsregister 

26 November 2018 1.1 Description: automatic data 

reconciliation XML interface 

Stiftung Zentrale Stelle 

Verpackungsregister 

22 October 2019 1.2 Description: producer volume 

report XML interface pursuant to 

section 10 VerpackG; smaller-

sized updates 

Stiftung Zentrale Stelle 

Verpackungsregister 

3 December 2019 1.3 System operator added Stiftung Zentrale Stelle 

Verpackungsregister 

18 August 2021 1.4 System operator added Stiftung Zentrale Stelle 

Verpackungsregister 

21 December 2021 1.5 System operator added Stiftung Zentrale Stelle 

Verpackungsregister 

4 May 2022 1.6 Update to the description of the 
XML brand name interface 

Stiftung Zentrale Stelle 

Verpackungsregister 

Table 1: Document version history 
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1 General 

 

 
1.1 Who is this guide for? 

This guide is for producers / initial distributors of packaging filled with goods in Germany who 

would like to use an XML interface to upload brand names and/or volume reports to the LUCID 

Packaging Register. This guide is also for those who would like to use automatic data 

reconciliation. 

 
1.2 When is it helpful to use the XML interface? 

Using XML interfaces can make entering data in the LUCID Packaging Register easier. This is 

especially true when larger volumes of data need to be entered, maintained or updated. One way 

would be, for example, exporting brand names from a merchandise management system as an 

XML file. That file could then be uploaded to the LUCID Packaging Register using an XML 

interface. 

 
1.3 General information about the XML interface 

 
1.1.1 Character encoding 

The character encoding for the XML file must be UTF-8-BOM. 

To check the character encoding of the file, you can use Notepad++ (for example). In the menu 

bar, click on Encoding and make sure that Encode in UTF-8-BOM is selected. 

LUCID only accepts Latin-1, Latin-2 and Latin-3 coding characters. 

 
1.1.2 XML file validation  

An XML file can be validated with the help of an XML schema. The usual file extension for an 

XML schema is '.xsd'. To carry out the check, you can use Notepad++ with the 'XML Tools' plugin 

(for example). 
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Follow these steps to validate the XML file: 

1. Open Notepad++ 

2. Click on File => Open, select the XML file you would like to validate and click Open 

3. Click on Plugins => XML Tools => Validate now 

 

4. Click on the button with the three dots, select the XML schema and confirm by clicking 

OK 

 

5. If the XML file is valid, the following message will be displayed: 
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2 Brand name interface 

 

 
2.1 How can I use the XML interface? 

To be able to use the XML interface, you need to create and upload a valid XML file with the 

correct schema. 

Below is a sample XML file for uploading brand names with explanations: 

 

 

Once the file is uploaded in LUCID, the following entries appear: 

 
 

 
2.2 Information about the elements 

The following presets are defined by the XML schema: 

• The first two lines and the last line are the 'bones' of the XML file. These lines may not 

be changed. 

• The third line shows the interface's version number. The current interface version 

number is 1.1. 

• Following that, the ListOfBrands begins. There can only be one ListOfBrands. 

• The ListOfBrands contains the individual brand names. Any number of brands can 

be created. If a brand is created, a BrandName must also be added. Brand names 

such as 'no name' or 'no description' are not permitted. The maximum number of 

characters is 255. A duplicate BrandName is not permitted. 
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• Permitted PackagingDetailCodes are 10, 20 or 30 

• 10: Packaging subject to system participation 

• 20: Packaging not subject to system participation 

• 30: both (10 and 20) If you place exclusively packaging subject to system 

participation or exclusively packaging not subject to system participation on 

the German market, the PackagingDetailCode may be left blank. 

 
2.3 Other information 

When uploading the XML file in LUCID, a valid (in relation to the XML schema) XML file can still 

be refused. The LUCID Packaging Register carries out other checks that are not covered by the 

XML schema (e.g. whether the PackagingDetailCode is valid). 

 
2.4 Creating XML files in Excel 2016 

1. Open Excel and under File => Options => Customise the Ribbon => 

Main Tabs, tick the Developer Tools box and then click on OK 
 

2. In the ribbon, click on Developer Tools => Source 

3. In the menu that opens, click on XML Mapping 
 

4. In the menu that opens, click on Add, select the XML schema and click on OK 
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5. The schema is now imported in Excel. Click on ListOfBrands and, pressing down on the 

mouse, drag the schema into the Excel table 

6. You can now enter your brand names under BrandName and under 

PackagingDetailCode or, for example, copy and paste from another Excel table. The 

important thing is to enter the brand names under BrandName and the corresponding 

code under PackagingDetailCodes next to the appropriate brand names. 

 

7. To export the brand names as an XML file, click on File => Export 

=> Change File Type => Save as Type => Save as 

8. Select XML File, select a file destination, enter a file name and save the file 

9. Because Excel cannot be used to directly create a valid XML file for the LUCID 

Packaging Register, the file needs further editing in a text editor 

10. Open the newly created XML file in a text editor (such as Notepad++) 

11. Select the entire ListOfBrands and copy the ListOfBrands from your newly created 

XML file to your clipboard 

12. Open the sample XML file 
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13. Delete the ListOfBrands from the sample XML file and paste the 

ListOfBrands from your clipboard into the XML file 

14. Click on File => Save as to save the new XML file 

15. Check the validity of the XML file by using the XML schema 
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3 Producer volume report interface (section 10 VerpackG) 

 

 
3.1 How can I use the XML interface? 

To be able to use the XML interface, you need to create and upload a valid XML file with the 

correct schema. 

In order to make XML data reporting as simple as possible, all of the information that is relevant 

for the fields in a manual report is included in the XML file. After the file has been uploaded, the 

data is displayed and must be confirmed by the user. 

Below is a sample XML file for uploading volume reports with explanations: 
 

 
3.2 Information about the elements 

• The first two lines and the last line are the 'bones' of the XML file. These lines may not 

be changed. 

• VersionNoInterface: the version number relates to the technical version of the interface; 

the current interface version number is 1.0. 
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• PackagingTypeCode: code for 'packaging' (V). Other options are technically possible, but 

not permitted at this time. For details, refer to Table 3: Packaging types. 

• TypeOfReportCode: code for initial planned volume report, intra-year volume report, year-

end volume report, supplementary volume report or deducted volumes. For details, refer 

to Table 4: Producer report types. 

• ReportingPeriodFrom: period of the report (date YYYY-MM-DD); only month and year are 

applied 

• ReportingPeriodTo: period of the report (date YYYY-MM-DD); only month and year are 

applied 

• SystemOperatorID: conclusive identification number of the system operator for the ZSVR. 

For details, refer to Table 5: System operators. 

• MaterialCode: code for material type. Depending on the reporting period, the material 

types are based on the Verpackungsverordnung (Packaging Ordinance: year-end report, 

supplementary volume report, deducted volume report for 2018) or the 

Verpackungsgesetz (Packaging Act: from 2019 onwards, even if filed in 2018). The 

MaterialCodes can be taken from Table 2: Material type overview. 

• Mass: packaging material mass in kg to the third decimal place without thousands 

separators (decimal place demarcated with comma). 

Reported volumes 

Depending on report types, a distinction needs to be made between different reported volumes. 

The report types initial planned volume report, intra-year volume report, year-end volume report 

and deducted volumes are always full reports. The supplementary volume report is an additive 

report. 

• Full report: provides the total volume for the reporting period. Where information already 

exists for a given reporting period, a new file will replace it as long as the correction window 

is still open. 

• Additive report: provides the difference between the previous and the new volume for the 

reporting period. Where information already exists for a given reporting period, the new 

information will be added to the existing information. Negative values can also be entered. 

 
3.3 Information about the codes  

The reports in 2019 for the 2018 reporting year must be filed according to the material types in 

the Verpackungsverordnung (VerpackV) exclusively. Reports for 2019 onwards are filed on the 

basis of the material types in the Verpackungsgesetz (VerpackG). 

 
Material type VerpackV 

MaterialCode 
VerpackG 
MaterialCode 

Glass 10000 10000 

PPC 20000 20000 

Tinplate 39000  

Ferrous metals  30000 

Aluminium 49000 40000 

Plastics 50000 50000 

Beverage carton packaging  60000 

Composite materials 79000  

Other composite packaging  70000 

Other materials 80000 80000 

Table 2: Material type overview 
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The packaging types are listed in the following table. At present, the only packaging type allowed is 

'packaging'. 

PackagingType PackagingTypeCode 

Packaging V 

Table 3: Packaging types 

 

Type of report TypeOfReportCode: Reported 
volumes 

Initial planned volume report HPM1 Full report 

Intra-year volume report HMM1 Full report 

Year-end volume report HJM1 Full report 

Supplementary volume report HNM1 Additive report 

Deducted volumes HAM1 Full report 

Table 4: Producer report types 

 

System operator SystemOperatorID 

INTERSEROH Dienstleistungs GmbH DE6005779374130 

Reclay Systems GmbH DE6005973594801 

RKD Recycling Kontor Dual GmbH & Co. KG DE6006382012686 

Der Grüne Punkt – Duales System Deutschland GmbH DE6004919627351 

Landbell AG für Rückhol-Systeme DE6005906579671 

Noventiz Dual GmbH DE6005959764031 

Zentek GmbH & Co. KG DE6007094250999 

Veolia Umweltservice Dual GmbH DE6007086225568 

ELS Europäische LizenzierungsSysteme GmbH DE6007168805143 

BellandVision GmbH DE6004738522858 

PreZero Dual GmbH DE6004844021815 

EKO-PUNKT GmbH & Co. KG DE6007780383579 

Recycling Dual GmbH DE6257129182400 

INTERSEROH+ GmbH DE6161328237553 

Altera System GmbH DE6229413357273 

Table 5: System operators 

 

3.4 Other information 

The XML file is not saved permanently by the ZSVR and only serves to transfer the data to the web 

interface. The rules for manually entering the data reports also apply to filing data via XML. In 

addition, there are technical plausibility checks, such as version, format, logic, completeness and 

structural checks. As such, a valid XML file (in relation to the XML schema) may be refused. Only 

once the XML file has been corrected, made free of any errors and uploaded can the data be saved. 

 
The 'ReportingPeriodFrom' and 'ReportingPeriodTo' must always be in the same calendar year. 

XML data reports that span multiple years are not permitted. In such a case, two files must be 

uploaded. 

The material codes in the XML file can be entered in any order. If the volume of a material is 0,000 

kg, then the entire MaterialCode with mass (including the Material start and end tag) can be left 

out as an alternative. 
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4 Automatic data reconciliation interface 

 

 
4.1 How can I use the XML interface? 

To be able to use the XML interface, you need to create and upload a valid XML file with the 

correct schema. Taxpayer reference numbers and VAT IDs are entered into this XML file. After a 

successful upload, an XML file will be available for download containing information for producers 

about whether they are registered in the LUCID Packaging Register as an active producer ('yes' 

or 'no'). 

Below is a sample XML file for automatic data reconciliation with explanations. Below is an 

example of a query of the registration status for three producers: 

 
4.2 Information on the elements of the XML file (upload) 

• The first two lines and the last line are the 'bones' of the XML file. These lines may not 

be changed. 

• VersionNoInterface: the version number relates to the technical version of the interface; 

the current interface version number is 1.0. 

• Taxnumber: taxpayer reference number or VAT ID of the producer to be queried. 

 
4.3 Other information 

When uploading the XML file in LUCID, a valid (in relation to the XML schema) XML file can still 

be refused. LUCID carries out other checks that are not covered by the XML schema. 
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4.4 XML file download 

Once an XML file has been successfully uploaded, an XML file with the requested information can be 

downloaded. 

Below is the XML file available for download: 
 

 
4.5 Information on the elements of the XML file (download) 

• VersionNoInterface: the version number relates to the technical version of the interface; 

the current interface version number is 1.0. 

• DateOfRequest: date the query is made. 

• DateOfCreation: date the file is created. 

• Taxnumber: taxpayer reference number or VAT ID of the producer to be queried. 

• Registered: information ('yes' or 'no') about whether an active producer is registered with 

the ZSVR and has consented to automatic data reconciliation. 

 
4.6 Creating an XML file for automatic data reconciliation in Excel 2016 

1. Open Excel and under File => Options => Customise the Ribbon => 

Main Tabs, tick the Developer Tools box and then click on OK 
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2. In the ribbon, click on Developer Tools => Source 

3. In the menu that opens, click on XML Mapping 
 

4. In the menu that opens, click on Add, select the XML schema and click on OK 

5. The schema is now imported in Excel. Click on ListOfManufacturers and, pressing down 

on the mouse, drag the schema into the Excel table 

6. You can now enter the taxpayer reference number and VAT IDs under Taxnumber 

or you can also, for example, copy and paste from another Excel table 
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7. To export the taxpayer reference numbers or VAT IDs, click on File 

=> Export => Change File Type => Save as Type => Save as 

8. Select XML File, select a file destination, enter a file name and save the file 

9. Because Excel cannot be used to directly create a valid XML file for LUCID, the file 

requires further editing in a text editor 

10. Open the newly created XML file in a text editor (such as Notepad++) 

11. Select the entire ListOfManufacturers and copy the ListOfManufacturers from 

your newly created XML file to your clipboard 

12. Open the sample XML file 

13. Delete the ListOfManufacturers from the sample XML file and paste the 

ListOfManufacturers from your clipboard into the XML file 

14. Click on File => Save as to save the new XML file 

15. Check the validity of the XML file by using the XML schema 


